3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 configure: configure-stamp
26 # Add here commands to configure the package.
35 build-stamp: configure-stamp
38 # Add here commands to compile the package.
40 #docbook-to-man debian/vym.sgml > vym.1
47 rm -f build-stamp configure-stamp
51 # Add here commands to clean up after the build process.
61 install -m 644 vym.desktop debian/vym/usr/share/applications/vym.desktop
62 # Add here commands to install the package into debian/vym.
63 $(MAKE) install DESTDIR=$(CURDIR)/debian/vym
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
70 # Build architecture-dependent files here.
71 binary-arch: build install
88 binary: binary-indep binary-arch
89 .PHONY: build clean binary-indep binary-arch binary install configure